Requirements

The requirements here presented, unless explicitly stated, are STRICT, and should be fullfilled in order to maximize the chances that MoKi works on your system.

  • PHP version 5.1.x or 5.2.x installed and working. MoKi should work with any PHP version 5.1.x or 5.2.x. MoKi has been successfully installed and tested with the following PHP versions: 5.1.6, 5.2.6, 5.2.8, 5.2.9, 5.2.10. The current MoKi version does not work properly with PHP 5.3.0.

  • Database Server MySql 5.0 or later installed and working. MoKi should work with any Database Server MySql 5.0 or later. MoKi has been successfully installed and tested with the following MySql versions: 5.0.77, 5.1.36, 5.1.33.

  • Apache Web Server 2.x installed and working. MoKi should work with any Apache Web Server version 2.x. MoKi has been successfully installed and tested with the following Apache Web Server versions: 2.2.11

  • PHP libxml library installed and working. MoKi has been successfully installed and tested with the following versions of PHP libxml library: 2.6.16, 2.7.3. WARNING: PHP libxml library version 2.7.2 (at least under linux/Mac OSX) seems to have a bug which prevent MoKi to work properly. Avoid using this version of the library.


If you don't want to deal with the installation of these softwares singularly, we suggest to use xampp. We have successfully installed and tested MoKi with the following version of xampp (it might work with other xampp version too):

  • Windows: 1.7.0, 1.7.1
  • Linux: 1.6.8a (not working with 1.7.0, 1.7.1 because of libxml library version 2.7.2)
  • Mac OS X: 0.7.3, 0.7.4 (not working with 1.0.1, 1.7.2 because of libxml library version 2.7.2)

  • MediaWiki version 1.15.1 

  • Semantic MediaWiki 1.4.3 MediaWiki Extension. Semantic MediaWiki has to be installed in "extensions" folder of Semantic MediaWiki.

  • Semantic Forms 1.8.3 MediaWiki Extension. Semantic Forms has to be installed in "extensions" folder of MediaWiki.

  • ParserFunctions MediaWiki Extension. For MediaWiki 1.15.1, use the REL1_15_1 branch. ParserFunctions has to be installed in "extensions" folder of MediaWiki.

  • Yahoo! User Interface Library (YUI) 2 (2.6 or later). YUI has to be installed in "extensions" folder of MediaWiki, in a folder called "yui".

  • Java version 1.6.0 or later. MoKi should work with any Java version 1.6.0 or later. We have successfully installed and tested with the following Java versions: 1.6.0_3, 1.6.0_10, 1.6.0_15

   
Avoid Blank spaces in the path!

In some situations, we experienced some problems if any of the installation path of JAVA, PHP and the webserver contains blank space, e.g "Program Files". For this reason we raccomend to use installation paths without blank spaces inside.

Optional Requirements

  • PHP zlib library is required if you want to export a bounch of eRDF files of processes in a single compressed file. If this library is not found in the system, this option will not be available in the tool.

Web Browsers

  • Moki has been deeply tested with Firefox 3.0.x, 3.5.x and 3.6.x. We suggest this browser to use MoKi.